What are the requirements to import PMI?

The new CALYPSO PMI interface is available as of CALYPSO 2016 (version 6.2). The only  requirement is a native CAD interface that supports PMI. Currently, the functional PMI technology is supported by 4 CAD systems.

  • Siemens NX from Siemens (from version NX 8)
  • Catia from Dassault Systemes (from version Catia V5)
  • Solidworks from Dassault Systemes (from Solidworks 2015)
  • ProEngineer / CREO from PTC (from CREO 2)

Standard formats such as STEP or JT currently only offer limited PMI functionality and are not yet supported for PMI import into CALYPSO.